Skip to main content
CallTower Solutions Center

BOC - Cloud Suite - Supported Browsers & Versions

Bridge Operator Console - Cloud Suite requires the following browser versions or greater.

TECHNICAL SPECS:

o    Browser based access (Chrome, Firefox, Edge, Safari, Opera)

o    Chrome is preferred and recommended

Minimum Required Browser Version: 

 

Browser

Version

Date

Chrome

68

Apr 2017

Firefox

54

Jun 2017

Edge

14

Aug 2016

Safari

10

Sep 2016

Opera

55

Aug 2017

  • Was this article helpful?